LibreELEC/OpenELEC Krypton templates?

Recommended Posts

McKentin    0
On 6 mei 2017 at 5:05 PM, exist2resist said:

You could pick up a 5450 for $30 on Amazon.

Sent from my LG-H915 using Tapatalk

I bought a 1050, i need the 4k hvec gpu support. 5450 doesn't support gpu 4k hvec. Thanks for the advice anyways.

Share this post

Link to post
Share on other sites
Drazzilb    0
On 3/30/2017 at 11:13 PM, Living Legend said:


Here's the rundown:


I found tweaks that were made on a nightly build that's actually already running Kodi 18.0.  These tweaks allowed LibreELEC to run in the manner we're looking, no dedicated graphics card on a VM.  Unfortunately, Kodi 18 has migrated to MyVideos108 rather than MyVideos107, so this wouln't help with our library syncing/updating goals.  So what I did was I took the source files from LibreELEC running Kodi 17.1, took the individual changes that were made to allow for us to be able to run without the GPU, compiled, and created what is essentially a new version of LibreELEC 8.0.


So yes, the end result of compiling the source code is an .img file which is precisely what we need to create a VM.  This will start out as our primary vdisk location.  Check out the below image to see how to set things up on the unRAID GUI:




I believe you could also set the IMG file as the "OS Install ISO" instead, but I've always gone the route shown above.  Probably no difference.


After hitting create, you'll get brought back to the unRAID VM GUI.  Click the green triangle and connect via VNC.  At this point, it should look like a standard LibreELEC install.  It will ask you for an install location, and the only option should be the "2nd vDisk Location" which you created above.  Allow it to clear/format and overwrite this disk when performing the install.  When done, it'll says it's time to reboot.  At this point, go back to the VM screen and force kill the VM.  Then tap the red square and go to "EDIT".  Go to the Primary vDisk location and select NONE.  You no longer want the VM to run off of the original .img file.  Now, the secondary vDisk which is what we just installed the OS to will become your main drive.


After saving your changes, go back and this time after clicking on the red square, select "EDIT XML":


cd2d87f87b0747b4a1eb448873e40313.pngThe XML is the blueprint for the VM, presenting information ranging from resource allocation to peripheral location.  Here's what I would do.  Again, this is guess work fudging, but it's what worked for me.  Find the bracket towards the middle bottom starting with <channel type='unix'> and delete it along with everything below it to the bottom.  Now copy and paste my XML and replace it:

<channel type='unix'>
      <source mode='bind' path='/var/lib/libvirt/qemu/channel/target/domain-LibreELEC - Krypton/org.qemu.guest_agent.0'/>
      <target type='virtio' name='org.qemu.guest_agent.0' state='disconnected'/>
      <alias name='channel0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    <input type='tablet' bus='usb'>
      <alias name='input0'/>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='vnc' port='5901' autoport='yes' websocket='5700' listen='' keymap='en-us'>
      <listen type='address' address=''/>
      <model type='virtio' heads='1' primary='yes'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    <memballoon model='virtio'>
      <alias name='balloon0'/>
      <address type='pci' domain='0x0000' bus='0x02' slot='0x03' function='0x0'/>

The first part of your XML is specific to your setup, referencing resource allocation as well as disk locations.  They second half represents some of the tweaks needed to be made to allow VNC to work.


After these changes, save and boot!


EDIT: @hernandito to answer your last question about version changing.  If I understand correctly, your goal was about updating libraries, so just make sure that all of your client devices along with this VM stay on Krypton.  They can move from 8.0.0 to 8.0.1 and beyond, as long as it's still on Krypton.  Once you move something off of Krypton and onto Kodi 18, it will be on a different database at which poitn you'll either have to roll it back, or move everything else up.  Fortunately, we also have a working file of Kodi 18 as this is where I got these fixes from, so we should be safeguarded for quite some time.


This worked Perfectly for me. Took me a bit. One thing to note is make sure of is to set the primary vDisk bus to SATA. This fixed an issue I had with the system not finding the img file.

Share this post

Link to post
Share on other sites
Maniac    0


I'm running LibreElec 8.0.1 generic as a VM on my unraid. When I watch LiveTV (tvheadend or iptv) after a while it hangs the entire VM and have to force stop via dashboard. Sometimes it can take hour or two sometimes a few minutes after restart. everything freezes and no response from remote. 


I have another VM that runs win10 and it runs just fine. Pinned 2 cores on each VM from a total of 4. LibreElec has 2GB ram dedicated. 


Is there any way I can find out what is happening here? 

Share this post

Link to post
Share on other sites
cpthook    0
Posted (edited)
On 5/18/2017 at 2:05 PM, Drazzilb said:

This worked Perfectly for me. Took me a bit. One thing to note is make sure of is to set the primary vDisk bus to SATA. This fixed an issue I had with the system not finding the img file.


Worked for me also!!  I'm adding this to my personal unRAID knowledge-base for creation of LibreELEC VM's going forward.

Edited by cpthook

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.