limetech

Version 6.3.0-rc1 Release Notes

Recommended Posts

unRAID OS version 6.3 is primarily a bug fix and package "catch up" release.  There is one interesting new feature:

 

Please refer to change log below for list of updated components.

 

Notably missing from the list is the latest docker component.  This is because certain changes in the docker API broke the Docker Manager in webGui.  This will be addressed in a subsequent -rc.

 

unRAID Server OS Change Log
===========================

Version 6.3.0-rc1 2016-10-05
----------------------------

Base distro (primary packages):

- btrfs-progs: version v4.7.2
- netatalk: version 3.1.10
- openssl: version 1.0.2j
- php: version 5.6.26
- qemu: version 2.7.0
- samba: version 4.5.0

Base distro (secondary packages):

- apcupsd: version 3.14.14
- bash: version 4.4.0
- curl: version 7.50.3
- diffutils: version 3.5
- e2fsprogs: version 1.43.3
- etc: version 14.2
- file: version 5.28
- fuse: version 2.9.7
- gawk: version 4.1.4
- gdbm: version 1.12
- glib2: version 2.46.2
- glibc: version 2.24
- glibc: version zoneinfo
- glibc-solibs: version 2.24
- gnutls: version 3.4.15
- jemalloc: version 4.2.1
- kmod: version 23
- libtasn1: version 4.9
- libxml2: version 2.9.4
- lvm2: version 2.02.161
- nano: version 2.7.0
- network-scripts: version 14.2
- nfs-utils: version 1.3.4
- openssl-solibs version: 1.0.2j
- pkgtools-14.2-noarch: version 13
- reiserfsprogs: version 3.6.25
- util-linux: version 2.28.2

Base distro (desktop GUI packages):

- freetype: version 2.6.5
- harfbuzz: version 1.3.0
- libXfont: version 1.5.2
- mesa: version 12.0.2
- mozilla-firefox: version 49.0.1
- xkeyboard-config: version 2.18
- xorg-server: version 1.18.4

Linux kernel:

- version 4.7.6
- aacraid: version 1.2.1-52011
- intel 10Gbit ethernet: revert to in-tree drivers
- r750: version 1.2.9-16_09_27

Management:

- bug fix: For file system type "auto", only attempt btrfs,xfs,reiserfs mounts.
- bug fix: For docker.img and libvirt.img, if path on /mnt/ check for mountpoint on any subdir component
- bug fix: During shutdown force continue if array stop taking too long.
- bug fix: Handle case in 'mover' where rsync may move a file but also return error status.
- md/unraid: Fix bug where case of no data disks improperly detected.
- webGui: Add "Shutdown time-out" control on Disk Settings page.
- webGui: bug fix: Cannot manually specify virtIO iso in VM settings
- webGui: other changes: refer to github commit log

Share this post


Link to post
Share on other sites

Tested new aacraid driver, so far looking good. Thanks for the update.

 

Share this post


Link to post
Share on other sites

Thank you very much for this release. Updated without issue and I've found SMB transfers to VM have improved greatly. Keep up the good work.

Share this post


Link to post
Share on other sites

For the first time ever I am seeing zero drops on eth0 and eth1 NICs.  Linux must have updated the Intel NIC drivers.  Very nice!

Share this post


Link to post
Share on other sites

Is docker not available on this rc or just not updated to the most recent version?  Just want to be sure before I try it out...

Thanks!

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Is docker not available on this rc or just not updated to the most recent version?  Just want to be sure before I try it out...

Thanks!

 

 

Sent from my iPhone using Tapatalk

Docker is available, just hasn't been updated to the latest version yet.  Same version of Docker that ships with 6.2.

Share this post


Link to post
Share on other sites

Is docker not available on this rc or just not updated to the most recent version?  Just want to be sure before I try it out...

Thanks!

 

 

Sent from my iPhone using Tapatalk

Docker is available, just hasn't been updated to the latest version yet.  Same version of Docker that ships with 6.2.

 

Cool! thanks...I'll give this a shot.

Share this post


Link to post
Share on other sites

Just finishing off a server backup and will be updating tonight. I use my vms heavily so will post back on how the QEMU update is working - anyone interested in some game tests like firestike to see the difference?

Share this post


Link to post
Share on other sites

Just finishing off a server backup and will be updating tonight. I use my vms heavily so will post back on how the QEMU update is working - anyone interested in some game tests like firestike to see the difference?

Sure!  Bring 'em on!

Share this post


Link to post
Share on other sites

newbie question - how do I upgrade from 6.2 to the rc1?  can't find links.

 

 

Thanks

 

 

:-[ :-[ :-[

 

 

 

Share this post


Link to post
Share on other sites

newbie question - how do I upgrade from 6.2 to the rc1?  can't find links.

 

install this plugin:

 

https://raw.githubusercontent.com/limetech/webgui/master/plugins/unRAIDServer/unRAIDServer.plg

Share this post


Link to post
Share on other sites

newbie question - how do I upgrade from 6.2 to the rc1?  can't find links.

 

 

Thanks

 

 

:-[ :-[ :-[

 

Read the other sticky in this board:

http://lime-technology.com/forum/index.php?topic=52532.0

 

 

Thanks. 

 

 

All good so far apart from my cache drive not being added on each reboot - the array starts, but have to stop and move cache drive from unassigned each time

dzmm-diagnostics-20161006-2004.zip

Share this post


Link to post
Share on other sites

All good so far apart from my cache drive not being added on each reboot - the array starts, but have to stop and move cache drive from unassigned each time

 

If you're using Chrome see this FAQ entry.

Share this post


Link to post
Share on other sites

I realise I might be asking for Pandora's Box to be opened with this, but:

 

Is Limetech considering publicly disclosing any sort of roadmap for unRAID? Upcoming features, planned improvements, thought philosophies, etc.?

 

I ask, because on a recent WAN Show, Linus mentioned that (paraphrasing) "unRAID has some really cool things to do with cloud storage/syncing coming in the next few months" and other than this, I'm not aware of anything in regards to unRAID's planned direction.

 

Any clarification here would be awesome.

Share this post


Link to post
Share on other sites

Upgraded with no serious issues - a few i did have;

 

Dynamix stating the array sat on the oage stating "starting services", refreshing the page showed everything to have already loaded

My vms threw a funky - something to do with an unsupported system type. Edited them to Q35-2.7 and they boot fine and do seem a little more responsive

 

Score from before the update;

http://www.3dmark.com/3dm/15285226?

 

2 Score from after - one with the latest nvidia driver

http://www.3dmark.com/3dm/15285541?

http://www.3dmark.com/3dm/15285724?

 

Yes my gpu is starting to show its age now since i'm rated lower than a Gaming Laptop....

 

I did try to run FireStrike extreme but this makes my vm grind to a hault and be unable to even reboot after it runs the "Gathering system info" screen

Share this post


Link to post
Share on other sites

Noticed a bit of an odd change, disks aren't spinning down automatically since the upgrade. Turned off a few busy dockers with no change.

Share this post


Link to post
Share on other sites

Change the default spin down time and apply it again

 

Sent from my LG-D852 using Tapatalk

 

 

Share this post


Link to post
Share on other sites

Thanks Squid, did that too and it may be a combination of that and my VM using a symlink to my steam library that live on one drive but may have left it scanning the \\tower\. It's working again! *facepalm* first rule of IT change one thing at a time not two... So it's one of the two.

Share this post


Link to post
Share on other sites

http://lime-technology.com/forum/index.php?topic=51605.msg497176#msg497176

 

Just test on this RC, if execute "new config" with keep data_disk config, those missing disk will be clear and array allow to start.

 

a) If no parity disks at all, permit start/auto-start for any present data disks.

b) If parity1 present (but parity2 not present), permit start/auto-start if parity is correct, and all the data devices are correct, but just in different slots.

 

If parity2 is present, all devices must be present and in their correct slots, no way to get around that one.

 

 

Sound good if (a) (b) will be true. thanks

Share this post


Link to post
Share on other sites

Hi Tom, just a quick reminder that you were going to update /usr/share/smartmontools/drivedb.h with each release.  It is a bit behind at this point.

Share this post


Link to post
Share on other sites

Hi Tom, just a quick reminder that you were going to update /usr/share/smartmontools/drivedb.h with each release.  It is a bit behind at this point.

I'll update it for rc2

Share this post


Link to post
Share on other sites

Hi Tom, just a quick reminder that you were going to update /usr/share/smartmontools/drivedb.h with each release.  It is a bit behind at this point.

I'll update it for rc2

Cool, thanks!

 

Sent from my ONEPLUS A3000 using Tapatalk

 

 

Share this post


Link to post
Share on other sites

OK so I had to restart unraid yesterday to do some system changes. My dynamic guide got stuck on starting services again on startup. What was interesting is that when stopping the array it also hung on stopping services.

 

I'm not sure if this is something that will be very easy to debug due to it just being a java script issue I would presume?

 

Also I've noticed my vms take for ever to start now. When you click start there is a good minute or so before the vm bios screens show. This is the same on seabios and ovmf  but it does take longer on seabios

 

I've separated the posts about 'very slow VM startup' into its own thread, found here.  Unfortunately the original post mentions a second issue, a hang when starting and stopping services.  Since I don't want to significantly edit all of these posts, I've left it, but the original poster may want to start another topic about that issue.

Share this post


Link to post
Share on other sites

There is an issue with OVMF_CODE-pure-efi.fd on 6.3! eschultz and I have dome some troubleshooting since I cant get GPU pass trough on OSX and I cant go in to the BIOS on 6.3. However OVMF_CODE-pure-efi.fd from 6.2.1 solved all my issues with VM on 6.3  8) 8)

 

Pleast try this and see if this have any effect on your issues  :D

 

//Peter

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.