linuxserver.io

[Support] Linuxserver.io - Plex Requests

Recommended Posts

Not at the moment

 

Anxiously but patiently keeping my eyes peeled for this to change.  Thank you for what you do.

 

obideuce: Because I have only elementary knowledge of Dockers, I'm not sure if this would work in the meantime or not.. much less how to apply it (I've grown reliant on docker containers being built for me, bad I know but..):  https://github.com/rogueosb/docker-ombi

Share this post


Link to post
Share on other sites

Sparklyballs actually did an Ombi container about a month ago, but we forgot about it, this reminded me and we've done a template tonight and released it....  ;D

 

It's not a drop in replacement for plexrequests though, it requires a fresh install.

Share this post


Link to post
Share on other sites

Sparklyballs actually did an Ombi container about a month ago, but we forgot about it, this reminded me and we've done a template tonight and released it....  ;D

 

It's not a drop in replacement for plexrequests though, it requires a fresh install.

 

Many thanks!  So very many thanks. :)

Share this post


Link to post
Share on other sites

Oh, cool, thanks guys. I found another one in CA that I setup, but I'll give yours a shot this weekend.

Share this post


Link to post
Share on other sites

Now that Ombi is out, will PlexRequests still receive updates, or should I grab the Ombi container now?

Share this post


Link to post
Share on other sites

This will still receive updates atm. That may change in the future, but for now, you're good.

Share this post


Link to post
Share on other sites
Posted (edited)

Just installed plex requests docker but can't seem to get to the WebUI.  The log shows that it is starting but somewhere it fails.  Any ideas with what is going wrong?  Here is the log:

*** Running /etc/my_init.d/firstrun.sh...
Starting container on Sat Mar 4 22:55:05 CST 2017
Updating repository

HEAD is now at 66e822c Fix issue sending movie to radarr when approval is needed
Already up-to-date.
Selecting the desired branch
Using the master branch
Already on 'master'
Your branch is up-to-date with 'origin/master'.
Fixing permissions
Updating meteor. . . may take a while if meteor servers are being slow. The web gui will not go up until update is completed and there will be another message about PlexRquests starting
=> Errors while initializing project:

While loading package fourseven:scss@3.4.1:
error: Command failed:

module.js:340
throw err;
^
Error: Cannot find module '../'

at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(/home/.meteor/packages/fourseven_scss/.3.4.1.rq7oh5++os.linux.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.linux.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1egyg5f/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)

npm ERR! Linux 4.9.10-unRAID
npm ERR! argv "node"
"/home/.meteor/packages/meteor-tool/.1.3.5_1.t8l6l2++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm"
"rebuild" "--no-bin-links" "--update-binary"
npm ERR! node v0.10.46
npm ERR! npm v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 8


npm ERR! Failed at the thread-sleep@1.0.4 install script 'node-pre-gyp install

--fallback-to-build'.
npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the thread-sleep
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs thread-sleep
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!
/home/.meteor/packages/fourseven_scss/.3.4.1.rq7oh5++os.linux.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.linux.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1egyg5f/npm-debug.log

module.js:340
throw err;
^
Error: Cannot find module '../'

at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous>
(/home/.meteor/packages/fourseven_scss/.3.4.1.rq7oh5++os.linux.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.linux.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1egyg5f/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)

npm ERR! Linux 4.9.10-unRAID
npm ERR! argv "node"
"/home/.meteor/packages/meteor-tool/.1.3.5_1.t8l6l2++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm"
"rebuild" "--no-bin-links" "--update-binary"
npm ERR! node v0.10.46
npm ERR! npm v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 8


npm ERR! Failed at the thread-sleep@1.0.4 install script 'node-pre-gyp install

--fallback-to-build'.
npm ERR! Make sure you have the latest version of node.js and npm installed.

npm ERR! If you do, this is most likely a problem with the thread-sleep
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs thread-sleep
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!
/home/.meteor/packages/fourseven_scss/.3.4.1.rq7oh5++os.linux.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.linux.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1egyg5f/npm-debug.log


Starting PlexRequests. The web gui will be up once the message 'App running at: http://localhost' is displayed
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 106
Mar 4 22:55:39 5422e7f8533c syslog-ng[113]: syslog-ng starting up; version='3.5.3'

[[[[[ /config/plexrequests-meteor ]]]]]

=> Started proxy.
Unexpected mongo exit code 14. Restarting.
=> Meteor 1.4.3.1 is available. Update this project with 'meteor update'.
Unexpected mongo exit code 14. Restarting.
Unexpected mongo exit code 14. Restarting.
Can't start Mongo server.
Unspecified unrecoverable error. Exit was not clean

 

Edited by afkrejci90

Share this post


Link to post
Share on other sites

I have everything working but when the request button is clicked, it just says "Requesting" forever and the request is never processed. Any ideas on what I may be doing wrong?

 

Untitled.jpg

Untitled2.jpg

Share this post


Link to post
Share on other sites

Not really, regardless I'd recommend switching to Ombi.

Share this post


Link to post
Share on other sites

Hey!

 

Trying to run the LS.IO docker for PlexRequests.  Installs no problem, I'm able to connect CP to it with no issue, but for some reason SickRage keeps showing an error whenever I click "Test Server" (both exist on the same unRaid server).  The logs don't show anything of use.  I've tried:

1) Verifying IP address and server port

2) Changing SR server port

3) Changing SR API key

4) Restarting SR

5) Restarting PlexRequests

6) Connecting to SR without and with SSL

7) Adding "SickRage Sub-Directory" of "/sickrage", "/", "/sickrage/", "/home"

 

and nothing has helped.  Any clue as to what is going on?  What additional information would you like to see?

 

Cheers,

Philip

Share this post


Link to post
Share on other sites

This image has been updated now. A manual update was pushed by @sparklyballs.

 

Our images are updated every friday at 11pm GMT and the update that fixed this bug was released after that.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.