linuxserver.io

[Support] Linuxserver.io - Plex Requests

Recommended Posts

linuxserver_medium.png

 

Application Name: Plex Requests

Application Site: http://plexrequests.8bits.ca/

Docker Hub: https://hub.docker.com/r/linuxserver/plexrequests/

Github: https://github.com/linuxserver/docker-plexrequests

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, rather use the linuxserver.io forum for support.

Share this post


Link to post
Share on other sites

not seeing this in the container list in unraid

 

**edit** nm, found your beta templates repo on github

Share this post


Link to post
Share on other sites

not seeing this in the container list in unraid

 

**edit** nm, found your beta templates repo on github

 

Why aren't you just using community applications?  ???

Share this post


Link to post
Share on other sites

I'm not able to have Couch and Sonarr connecting.  It always give "error!".  I did put my Server's IP + the Port, and API key, etc.  doesn't seems to connect....

Share this post


Link to post
Share on other sites

Is this container is working for anyone ??

 

I have the Sonarr test sucessful, but trying to add something in TV shows always fail.  For Couch, it doesn't even pass the "Test"...

 

 

Share this post


Link to post
Share on other sites

Is this container is working for anyone ??

 

I have the Sonarr test sucessful, but trying to add something in TV shows always fail.  For Couch, it doesn't even pass the "Test"...

 

Working OK for me...  ???

Share this post


Link to post
Share on other sites

For me, it runs, but adding my Couch (192.168.2.6 - Unraid IP), using default 5050 port, with the API and I tried with or without the urlbase /couch.  Always errors.  For Sonnar, I added it, but if i try adding something, it always fail.

 

How yours is configured if it works ??

Share this post


Link to post
Share on other sites

This broken for anyone else now?

I actually can't get anyone's Plex Request docker to run now.

Even tried manually making one myself. =(

 

 

- NinthWalker

Share this post


Link to post
Share on other sites

What is the difference between Linuxserver and Isiodev?

 

Is there any place to request/make a wish for a docker, either here or on the linuxserver forum? Had been perfect with a onedrive docker to backup pictures and documents, since I get 1TB with office 365.

Share this post


Link to post
Share on other sites

Why aren't you just using community applications?  ???

 

I like to keep things clean.

 

Fair enough, but CA is one plugin along with powerdown that are in my opinion, just essential...

Share this post


Link to post
Share on other sites

For me, it runs, but adding my Couch (192.168.2.6 - Unraid IP), using default 5050 port, with the API and I tried with or without the urlbase /couch.  Always errors.  For Sonnar, I added it, but if i try adding something, it always fail.

 

How yours is configured if it works ??

 

Sorry, forgot about this....  :-\

 

Here's how I have mine configured....

 

uB8effR.png

GC5LoGJ.png

 

Share this post


Link to post
Share on other sites

Ok, I have this exact same config, it doesn't work for me.

 

Tried the Other Docker of PlexRequests.  It works, but not support the webroot like yours... so I can't use it either.  I'll try again yours to see if it works.  I saw that it wasn't updating to latest version.  Maybe it was badly installed.

 

** EDIT **

 

Strange, now it works very good! So it is all good!

Share this post


Link to post
Share on other sites

Version 1.7.3 was released... It appears that the version is locked in the Dockerfile, could you please update it? It fixes a rather critical bug with TV shows.

 

Also, I don't see this docker on GitHub... Has it not been released as open source?

Share this post


Link to post
Share on other sites

Version 1.7.3 was released... It appears that the version is locked in the Dockerfile, could you please update it? It fixes a rather critical bug with TV shows.

 

Also, I don't see this docker on GitHub... Has it not been released as open source?

 

lol, look a little harder...

 

https://github.com/linuxserver/docker-plexrequests

Share this post


Link to post
Share on other sites

Well his username is appropriate....

Always good for a morning smile

Share this post


Link to post
Share on other sites

Does this container auto update? Mine is stuck on 1.7.2 while 1.7.4 is out.

 

What's interesting is, I set this up yesterday for the first time and it did the 1.7.2 version instead of the 1.7.4 version which looks like has been out for a few days now.

Share this post


Link to post
Share on other sites

Does anyone have this docker hosted on the web for external users to be able to make requests? I'm not well versed in these sorts of things and I'm trying to figure out how I am supposed to get this working with people outside the network.

 

 

Also, when setting up Couchpotato and Sickrage, what does the app mean when it asks me for Sub directories?

Share this post


Link to post
Share on other sites

Does anyone have this docker hosted on the web for external users to be able to make requests? I'm not well versed in these sorts of things and I'm trying to figure out how I am supposed to get this working with people outside the network.

 

 

Also, when setting up Couchpotato and Sickrage, what does the app mean when it asks me for Sub directories?

 

Firstly you need a domain name of some sort.  Then you need to get that domain name to point to your WAN IP (You'll need to know if it's dynamic or fixed)

 

Then you have two options, one is to open the port on your router and forward it to plexrequests.  You could forward port 80 on your router to port 3000 on your Unraid box, that way you wouldn't need to type the port number after your domain name.

 

The second option is to setup a reverse proxy which I do with Apache, but you will have to do some manual config of Apache and ideally implement SSL.  Then you use Apache as a reverse proxy to plex requests and whatever other apps you want to make available.

 

The subdirectories (or webroot) are a way of configuring applications to be compatible with  reverse proxy.  For example if you normally reach couchpotato on

 

server:5050 then going to different pages will render links like so

 

tower:5050

tower:5050/home

tower:5050/movies

 

which screws the reverse proxy up which tries to access things from the wan which will be setup like this

 

server.com/couchpotato

 

then when you try to go to

 

server.com/home

server.com/movies

 

it will fail so instead by adding a subdirectory you get links like so

 

server.com/couchpotato

server.com/couchpotato/home

server.com/couchpotato/movies

 

accordingly on you lan it will be

 

tower:5050/couchpotato

tower:5050/couchpotato/home

tower:5050/couchpotato/movies

 

There's a guide to setting up a reverse proxy here on linuxserver.io.  I use the ls.io Apache container but Nginx is another option.

Share this post


Link to post
Share on other sites

It just creates an empty folder for me; nothing else.

 

Update; now it has the db folder with content but no initial page

Share this post


Link to post
Share on other sites

Movies are working fine, but trying to add TV shows gives the error "Couldn't submit request, please try again" and the log shows "Error getting TVDB ID, none found!" It says this for any show I try

Share this post


Link to post
Share on other sites

Movies are working fine, but trying to add TV shows gives the error "Couldn't submit request, please try again" and the log shows "Error getting TVDB ID, none found!" It says this for any show I try

 

I'm seeing this issue too at the moment and it was working fine previously so I can only assume it's a problem with the TVDB api.

Share this post


Link to post
Share on other sites

Movies are working fine, but trying to add TV shows gives the error "Couldn't submit request, please try again" and the log shows "Error getting TVDB ID, none found!" It says this for any show I try

 

So after a bit of investigating it turned out it was indeed an error with the TVDB api that was fixed in 1.7.4 asked Sparklyball to trigger an update to the container, turns out he'd already done it... Got to hand it to him sometimes, he's efficient.  ;D

 

Check for docker updates and update the container.  Should be good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.