hurricanehrndz

New Emby Docker

336 posts in this topic

Hi Guys,

 

We the developers of Emby have started the development of new container for Emby, right now this is consider testing but it is very stable. Please see the following for more info:

 

https://github.com/MediaBrowser/Wiki/wiki/Docker

 

If you would like to dictate the development of the container please come see us on our forums. Your feedback is much appreciated.

http://emby.media/community/index.php?/topic/28661-docker-new-testing-image/

 

 

You can also find our official template here:

https://github.com/MediaBrowser/Emby.Build/tree/master/unraid-templates/Emby

 

2

Share this post


Link to post
Share on other sites

Hello,

 

I have 2 quick questions...

 

1.  Can we test this out now?  How?  Do I just add the template repo to the Docker Repo tab in Unraid?

 

2.  Can we use our existing configuration?

 

Looking forward to try this out!

 

Thanks

0

Share this post


Link to post
Share on other sites

I think it's also moved from hurricane's personal repo to the official MB repo.  And a change in base image as well.

 

0

Share this post


Link to post
Share on other sites

@airbillion - I changed from the normal container to this by just pointing it at my emby config folder - No problems at all

 

@Hurricane - Is there anything in particular you would like us test out?

0

Share this post


Link to post
Share on other sites

@airbillion - I changed from the normal container to this by just pointing it at my emby config folder - No problems at all

 

@Hurricane - Is there anything in particular you would like us test out?

 

Did you have to ad the new repo to the Unraid docker repo tab?

 

I will give it a shot.

 

Thanks!

0

Share this post


Link to post
Share on other sites

 

You can also find our official template here:

https://github.com/MediaBrowser/Emby.Build/tree/master/unraid-templates/Emby

 

What value should be assigned to EMBYSERVER_USER?  The name of the account you use to manage Emby?

 

John

 

I wondered that and just left it as is and used my current appdata, loaded up just fine....  ???

 

Strangely though, although the webui is defined in the xml I don't get a link to it in the dropdown box when I click on the icon (If you know what I mean)

 

0

Share this post


Link to post
Share on other sites

 

You can also find our official template here:

https://github.com/MediaBrowser/Emby.Build/tree/master/unraid-templates/Emby

 

What value should be assigned to EMBYSERVER_USER?  The name of the account you use to manage Emby?

 

John

 

I wondered that and just left it as is and used my current appdata, loaded up just fine....  ???

 

Strangely though, although the webui is defined in the xml I don't get a link to it in the dropdown box when I click on the icon (If you know what I mean)

 

I see the same behavior.  Weird.  Still reachable though.

 

Version 3.0.5785.0

 

John

0

Share this post


Link to post
Share on other sites

 

You can also find our official template here:

https://github.com/MediaBrowser/Emby.Build/tree/master/unraid-templates/Emby

 

What value should be assigned to EMBYSERVER_USER?  The name of the account you use to manage Emby?

 

John

 

I wondered that and just left it as is and used my current appdata, loaded up just fine....  ???

 

Strangely though, although the webui is defined in the xml I don't get a link to it in the dropdown box when I click on the icon (If you know what I mean)

 

I see the same behavior.  Weird.  Still reachable though.

 

Version 3.0.5785.0

 

John

 

Same here

0

Share this post


Link to post
Share on other sites

As an aside I lost my webui links from the drop downs for all my containers back in the late betas for v6.  Never got around to troubleshooting after my comment in the beta thread got lost.  New containers have the correct links but old ones don't.  Deleting and recreating from local templates didn't fix it, if I recall. 

 

0

Share this post


Link to post
Share on other sites

Ok i already have the current emby server. How do install this one.....

 

The instructions for the slow one like me..

0

Share this post


Link to post
Share on other sites

Why a new Docker instead of just updating the exiting one?

Because it's for testing purposes. Once this is ready and we feel that our user base is happy with the major changes we are making we will upgrade the existing one to this format.

0

Share this post


Link to post
Share on other sites

I think it's also moved from hurricane's personal repo to the official MB repo.  And a change in base image as well.

Yes there is a lot of information in the wiki in regards to all the changes made.

0

Share this post


Link to post
Share on other sites

@airbillion - I changed from the normal container to this by just pointing it at my emby config folder - No problems at all

 

@Hurricane - Is there anything in particular you would like us test out?

Nope, We just want to make sure all the features your accustomed to are there and that our users aren't cut off guard by all the changes.

0

Share this post


Link to post
Share on other sites

 

You can also find our official template here:

https://github.com/MediaBrowser/Emby.Build/tree/master/unraid-templates/Emby

 

What value should be assigned to EMBYSERVER_USER?  The name of the account you use to manage Emby?

 

John

 

I wondered that and just left it as is and used my current appdata, loaded up just fine....  ???

 

Strangely though, although the webui is defined in the xml I don't get a link to it in the dropdown box when I click on the icon (If you know what I mean)

Yes I have experienced this myself. This is the first time this has happened and I'm still trying to figure out why

 

0

Share this post


Link to post
Share on other sites

Will the "original" emby docker have the latest version of emby?  Or do I need to remove that docker and install the new docker you are discussing.  I did not quite follow if the "original" docker will be unsupported and should be removed

 

 

Thanks

 

 

0

Share this post


Link to post
Share on other sites

Testing will be removed and the original will get updated. But you will need to update your templates.

 

Old template is not compatible with new template.

 

https://github.com/MediaBrowser/Wiki/wiki/Docker-Getting-Started

 

I added https://github.com/MediaBrowser/Emby.Build/tree/master/unraid-templates/emby to my template repositories updates and got a version, seem to work just fine.

0

Share this post


Link to post
Share on other sites

There is, this is a bug in dockerman where the webui link does not get updated. The emby wiki will be updated with instructions shortly on how to get the link back. Thanks.

0

Share this post


Link to post
Share on other sites

Under what name should I be adding the repository to CA?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.