linuxserver.io

[Support] Linuxserver.io - OpenVPN-AS

Recommended Posts

41 minutes ago, mrbilky said:

 

So I'm determined to make this work

 

my first question is I pulled down the docker and when its set to host it will not connect, if I set it to bridge it will and I can get to the setup for openVPN I did not change anything else in the setup screen, where do I find what I need to change so host will open or does it matter?

 

Are you using a bonded network?

 

43 minutes ago, mrbilky said:

 

I am willing to pay for a dns account how is dyndns any opinions?

I like DuckDNS docker.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, wgstarks said:

Are you using a bonded network?

 

I like DuckDNS docker.

According to my settings yes it is set to bonding, should I change that? And if bridging isn't needed that is on as well from what I've read those 2 settings seem to be for VM use for which at this time I have no interest in if that helps

Edited by mrbilky

Share this post


Link to post
Share on other sites
2 hours ago, mrbilky said:

According to my settings yes it is set to bonding, should I change that? And if bridging isn't needed that is on as well from what I've read those 2 settings seem to be for VM use for which at this time I have no interest in if that helps

Try following these instructions for changing the variable INTERFACE. IIRC you need to use br0 rather than the default eth0. There is also some good info there for other necessary settings.

Share this post


Link to post
Share on other sites
On 9/30/2017 at 3:51 AM, CHBMB said:

It does for the most part. What is the ip address of your Unraid server?

 

The ip address of my unraid server is 192.168.2.134

Share this post


Link to post
Share on other sites

I've got a problem when i try to start the webserver. I always get this error message:
 

process started and then immediately exited: ['Fri Oct 13 23:59:16 2017 ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)']
service failed to start or returned error status

 

my docker run command is this:

/plugins/dynamix.docker.manager/scripts/docker create --name="openvpn-as" --net="host" --privileged="true" -e TZ="Europe/Berlin" -e HOST_OS="unRAID" -e "TCP_PORT_943"="943" -e "TCP_PORT_9443"="9443" -e "UDP_PORT_1194"="1194" -e "INTERFACE"="bond0" -e "PGID"="100" -e "PUID"="99" -v "/mnt/cache/appdata/openvpn-as":"/config":rw --cpuset-cpus=0-4,8-12 linuxserver/openvpn-as

 

i tried multiple times reinstalling the docker with removing the config folder and also removing the docker with all their images without success.

 

I hope someone can help me with this.

 

EDIT: a simple restart of the server fixed the problem....

Edited by DaLeberkasPepi

Share this post


Link to post
Share on other sites

Hey guys,

I have successfully set everything up and it works perfectly. SSL and all. However, when a user connects and clicks "more details..." when asked "Allow VPN connection to...", the info presents the whole config file - something that doesnt feel right. Even the SSL information is there in plain sight. 

 

Is that normal? Can one edit the data that is shown in this "More information..." thing? If so, how ?

 

 

I appreciate any help !

ovpn.jpg

Share this post


Link to post
Share on other sites

So far I have this OpenVPN docker working great with both my laptop and phone.  How do I upgrade the docker to the latest version of OpenVPN?

 

Thanks

Share this post


Link to post
Share on other sites
23 minutes ago, puma1824 said:

So far I have this OpenVPN docker working great with both my laptop and phone.  How do I upgrade the docker to the latest version of OpenVPN?

 

Thanks

Restart the docker and it will pull the latest version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.