coppit

Container for No-IP dynamic DNS updates

Recommended Posts

for some reason I cannot get this to work after having to rebuild all of my dockers because I deleted everything on accident. 

 

Do I need to delete anything from the conf file? I added my user, passwd, and domain. do i need to add anything else?

 

Share this post


Link to post
Share on other sites
On 4/4/2017 at 11:06 PM, dranani said:

Do I need to delete anything from the conf file? I added my user, passwd, and domain. do i need to add anything else?

 

Does your password have fancy characters like $"! or '  ? If so, you'll want to put it in either single quotes or double quotes, whichever you aren't using. And if you're using both, I'll have to give you special instructions. :)

 

What does the log say?

Share this post


Link to post
Share on other sites
21 hours ago, coppit said:

 

Does your password have fancy characters like $"! or '  ? If so, you'll want to put it in either single quotes or double quotes, whichever you aren't using. And if you're using both, I'll have to give you special instructions. :)

 

What does the log say?

I meant to edit my post, I figured it out. It was just an error on my part. I didn't read well enough

Share this post


Link to post
Share on other sites

DOMAINS='xxxxxx.hopto.me'

This is what I have the config file set with (x's are replaced with my actual hostname) and I get this error in the logs every time I start the docker:
Please enter your domain/group list in noip.conf

Any help would be greatly appreciated!

Thank you!

Share this post


Link to post
Share on other sites
On 5/22/2017 at 9:21 AM, veritas2884 said:

Please enter your domain/group list in noip.conf

 

It thinks that you still have the default value of "foo.ddns.net" set. Most likely you didn't attach your data disk to /config properly.

  • Upvote 1

Share this post


Link to post
Share on other sites
15 hours ago, coppit said:

 

It thinks that you still have the default value of "foo.ddns.net" set. Most likely you didn't attach your data disk to /config properly.

That was it. It generated the config file, but wasn't pointed to the place where it generated. I fixed that and am in business. Thank you!

Share this post


Link to post
Share on other sites

Hi,

 

I installed the NO-IP docker yesterday afternoon, filled in the details inf the config file, NO-IP then created the no-ip2.generated file and everything appears to be working. When I first started the Docker it then updated my NO-IP account with the IP address I am running on, but it appears it hasn't updated since. I logged into my NO-IP account, went to the manage hostname page, and clicked on the info icon and its showing last updated 22 hours ago i.e. when I first started the Docker. It hasn't updated since.

 

I have checked the Docker log and cannot see any problems and I see this being generated every min:

 

Process 18, started as noip2-x86_64 -c /config/no-ip2.generated.conf, (version 2.1.9)
Using configuration from /config/no-ip2.generated.conf
Last IP Address set ***************
Account ***************
configured for:
***************
Updating every 30 minutes via /dev/eth0 with NAT enabled.

 

The Last IP address set is my correct IP address, the Account shows the correct email address, and the configured for show the correct hostname.

 

Am I missing something?

Share this post


Link to post
Share on other sites
On 7/23/2017 at 9:10 AM, apefray said:

When I first started the Docker it then updated my NO-IP account with the IP address I am running on, but it appears it hasn't updated since.

 

I'm not sure I trust the "last updated" info on the webpage. I ran strace on my server, and attached it to the noip process. Every 20 minutes it woke up and talked to http://ip1.dynupdate.no-ip.com. The web page finally did change after a couple of hours. (Maybe sooner -- I wasn't watching it carefully.)

 

You can do it yourself to see if it's waking up and doing work. Run:

strace -rp $(pgrep noip2)

 

Share this post


Link to post
Share on other sites

Hi coppit,

 

I'm having the same issue as apefray - I've had noip docker running for a month, it showed the same message. 3 weeks in I got an email from noip saying I had to manually renew as I was coming up to the end of the month!

 

I'm not a networking guru but I've noticed something with my openvpn, which is installed and working, and I noticed for some reason it connects through the bond0 and not eth0 interface. Perhaps this is the issue here? Is there a way to specify a variable in the config file to try connect to noip through bond0?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.