publicENEMY

smtp mail not working

6 posts in this topic

Hi,

 

when i type

echo -e "Subject: a test\n\nThis is the email body." | ssmtp -d root

 

i get this

root@Tower:/# echo -e "Subject: a test\n\nThis is the email body." | ssmtp -d root
[<-] 220 mx.google.com ESMTP v6sm13620750pbu.41
[->] HELO smtp.gmail.com
[<-] 250 mx.google.com at your service
[->] MAIL FROM:<root@>
[<-] 530 5.5.1 http://support.google.com/mail/bin/answer.py?answer=14257 v6sm13620750pbu.41
ssmtp: 530 5.5.1 http://support.google.com/mail/bin/answer.py?answer=14257 v6sm13620750pbu.41
root@Tower:/#

 

Here are my smtp setting

Forward "root" email to: [myothergmail@gmail.com] Enter the e-mail account where mail to root will be forwarded.

E-Mail Server:[smtp.gmail.com:587] Mail Server Address used to send e-mail.

Use TLS?(YES/NO): [YES] If using a secure connection to the mail-server, set this to YES.

Mail ID:[mygmail@gmail.com] Your e-mail account on the mail server. (just the ID without the @server.com) Needed if your mail server requires authorization, leave blank otherwise.

Mail Password:[mygmail password] The e-mail password used when SENDING e-mail. (sometimes different than the one used to read mail) Needed if your mail server requires authorization, leave blank otherwise.

Mail Domain:[mygmail@gmail.com] Mail originates from this domain. (For many E-mail servers you can use "localhost", for gmail you can use "youraccount@gmail.com")

From Line Override (YES/NO): [YES] Make message appear to originate from mail server.

Re-Write Domain: [blank] If non-blank, make mail appear to come from domain. (Some mail hosts will not allow the mail to appear from elsewhere, so leave this blank unless you need to specifiy an alternate domain of origin)

RevAliases :[blank] If non-blank, alias mail from "root" to come from youraccount@yourserver.com. ( use: "root:youraccount@yourserver.com" ) Some mail servers will not allow mail from "root" without it being aliased to your own account.

 

what should i do?

 

thanks.

0

Share this post


Link to post
Share on other sites

that is exactly how mine is set up.

 

the exception is i forward it to my Hotmail account

 

 

http://support.google.com/mail/bin/answer.py?hl=en&answer=14257

the error is your ID or Password. verify it is correct? log into the account on your pc to make sure it is activated and not locked out?

change your password to a stronger one, you might be getting  the password is to weak pop-up.

0

Share this post


Link to post
Share on other sites

that is exactly how mine is set up.

 

the exception is i forward it to my Hotmail account

 

 

http://support.google.com/mail/bin/answer.py?hl=en&answer=14257

the error is your ID or Password. verify it is correct? log into the account on your pc to make sure it is activated and not locked out?

change your password to a stronger one, you might be getting  the password is to weak pop-up.

Are there any characters in the password or login that might have special meaning to the bash shell?  (Quote marks, #, $, @, <, >)
0

Share this post


Link to post
Share on other sites

that is exactly how mine is set up.

 

the exception is i forward it to my Hotmail account

 

 

http://support.google.com/mail/bin/answer.py?hl=en&answer=14257

the error is your ID or Password. verify it is correct? log into the account on your pc to make sure it is activated and not locked out?

change your password to a stronger one, you might be getting  the password is to weak pop-up.

Are there any characters in the password or login that might have special meaning to the bash shell?  (Quote marks, #, $, @, <, >)

 

well, i guess there is. my username contains dot in the middle, like not.me@gmail.com, and the password is "notme".

 

i tried putting "" for everything(email id) that contains dot in the middle. still no go.

 

root@Tower:~# echo -e "Subject: a test\n\nThis is the email body." | ssmtp -d root

[<-] 220 mx.google.com ESMTP w6sm16199032pbo.55

[->] EHLO smtp.gmail.com

[<-] 250 ENHANCEDSTATUSCODES

[->] STARTTLS

[<-] 220 2.0.0 Ready to start TLS

[->] HELO smtp.gmail.com

[<-] 250 mx.google.com at your service

[->] MAIL FROM:<root@>

[<-] 530 5.5.1 http://support.google.com/mail/bin/answer.py?answer=14257 w6sm16199032pbo.55

ssmtp: 530 5.5.1 http://support.google.com/mail/bin/answer.py?answer=14257 w6sm16199032pbo.55

root@Tower:~#

 

i just noticed that when i put "" for email id, the email id are not saved and the textbox became empty. i guess "" are considered illegal and not saved.

 

thanks.

0

Share this post


Link to post
Share on other sites

i just add my experience as the same thing happened to me as well.

 

my password starts with an $ and i got the same error.

 

 

 

on the unmenu settings page for the mail client i entered my passwort, i.e. $1mypassword11, and it was saved as mypassword11

 

then i changed my gmail password only to get this done.

i removed all $ and only added a & as a special character.

 

when i now save the password, the & is replaced by

||vAUTH_PASS=||

 

 

is there some way to escape special characters here?

0

Share this post


Link to post
Share on other sites

I found an easy way of dealing with this issue.

 

 

go to your flash drive (boot)

 

edit the file

boot/packages/mail-ssmtp-unmenu-package.conf

 

on line 21 or so.. you will find your password settings. it needs to look like below:

PACKAGE_VARIABLE Mail Password||vAUTH_PASS=YOUR_PASSWORD||...

 

paste it there. save the file. check "install on reboot" for the mail package in unmenu and reboot your server.

 

it worked well with my & special character and hopefully with $ and "" as well

 

cheers

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.