AdamT

New unMenu Package: MRTG... any interest?

Recommended Posts

no its all one line according to n++

 

Huh, I'm stumped.  Send me the mrtg.cfg file as a PM and I'll have a look.

im an idiot.  :-[

 

I did some testing with oids instead and it worked fine which told me the mibs where not being loaded. looked in the config

 

#LoadMIBs: /usr/share/snmp/mibs/UCD-SNMP-MIB.txt,/usr/share/snmp/mibs/TCP-MIB.txt

 

dang you '#'

 

seems to be working now, no more emails and logs have real data in them

 

 

off to make a user script so unraid will stop cleanly

Share this post


Link to post
Share on other sites

I don't understand.  I am having the same problem with emails stating 'Unknown SNMP var ssCpuRawUser', etc...

 

Should I add this line to my mrtg.cfg to fix the issue?

 

LoadMIBs: /usr/share/snmp/mibs/UCD-SNMP-MIB.txt,/usr/share/snmp/mibs/TCP-MIB.txt

Share this post


Link to post
Share on other sites

I don't understand.  I am having the same problem with emails stating 'Unknown SNMP var ssCpuRawUser', etc...

 

Should I add this line to my mrtg.cfg to fix the issue?

 

LoadMIBs: /usr/share/snmp/mibs/UCD-SNMP-MIB.txt,/usr/share/snmp/mibs/TCP-MIB.txt

 

yea put it up at the top

Share this post


Link to post
Share on other sites

I don't understand.  I am having the same problem with emails stating 'Unknown SNMP var ssCpuRawUser', etc...

 

Should I add this line to my mrtg.cfg to fix the issue?

 

LoadMIBs: /usr/share/snmp/mibs/UCD-SNMP-MIB.txt,/usr/share/snmp/mibs/TCP-MIB.txt

 

yea put it up at the top

 

That worked great.  Thanks. 

Share this post


Link to post
Share on other sites

hello, my mrtg is showing only the eth0 stats..

 

how i can add others?

 

edit: another problem

 

crontab seems not working, it's not being updated auto

 

if i run the command on telnet, it update

 

here's a log from syslog

Apr 24 19:45:01 unRAID crond[1308]: exit status 1 from user root env LANG=C /usr/bin/mrtg --lock-file /tmp/mrtg_lockfile /boot/config/mrtg.cfg
Apr 24 19:45:01 unRAID kernel: crond[13486]: segfault at b78f851c ip b78f851c sp bfa30524 error 15 in ld-2.11.1.so[b78f8000+1000]
Apr 24 19:46:01 unRAID crond[1308]: exit status 1 from user root /usr/lib/sa/sa1 1 1

 

Share this post


Link to post
Share on other sites

hello, my mrtg is showing only the eth0 stats..

 

how i can add others?

 

edit: another problem

 

crontab seems not working, it's not being updated auto

 

if i run the command on telnet, it update

 

here's a log from syslog

Apr 24 19:45:01 unRAID crond[1308]: exit status 1 from user root env LANG=C /usr/bin/mrtg --lock-file /tmp/mrtg_lockfile /boot/config/mrtg.cfg
Apr 24 19:45:01 unRAID kernel: crond[13486]: segfault at b78f851c ip b78f851c sp bfa30524 error 15 in ld-2.11.1.so[b78f8000+1000]
Apr 24 19:46:01 unRAID crond[1308]: exit status 1 from user root /usr/lib/sa/sa1 1 1

 

 

i dont know how to fix your crontab problem. but here is my config. Ignore the drive temp setup, I have to do it another way.

 

mrtg.cfg

Share this post


Link to post
Share on other sites

it's always showing up on syslog

 

Apr 30 01:45:01 unRAID crond[1235]: exit status 1 from user root env LANG=C /usr/bin/mrtg --lock-file                                                                                    /tmp/mrtg_lockfile /boot/config/mrtg.cfg

 

but whitout a real update on stats..

Share this post


Link to post
Share on other sites

I'm not sure what version of your MRTG conf I am using but I've been getting this error email while my disk2 is being rebuilt.  I upgraded from a 250Gb drive to a 2Tb drive.

 

SNMP Error:

Received SNMP response with error code

error status: noSuchName

index 2 (OID: 1.3.6.1.4.1.2021.9.1.9.2)

SNMPv1_Session (remote host: "localhost" [127.0.0.1].161)

                community: "public"

                request ID: 1716314557

              PDU bufsize: 8000 bytes

                  timeout: 2s

                  retries: 5

                  backoff: 1)

at /usr/bin/../lib/mrtg2/SNMP_util.pm line 497

SNMPGET Problem for dskPercent.1 dskPercent.2 sysUptime sysName on public@localhost::::::v4only

at /usr/bin/mrtg line 2330

2012-06-04 11:05:01: ERROR: Target[server.disk][_IN_] ' $target->[9]{$mode} ' did not eval into defined data

2012-06-04 11:05:01: ERROR: Target[server.disk][_OUT_] ' $target->[9]{$mode} ' did not eval into defined data

 

I'm assuming that it will go away once the drive has finished its rebuild, but I was wondering if there was a way to disable the emails from within MRTG's settings?  I totally forgot I had this running, I usually check it now and again to see how/what is being used resources wise.

 

Adam T, has much changed in the conf?  I've running the original release when you got 4.7 working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.