spidi

Plex Media Server

1667 posts in this topic

Trying to install and i get this error

 

 

install: missing destination file operand after `plex-0.9.3.5-noarch-0.2ds.plg'

Try `install --help' for more information.

 

thoughts?

0

Share this post


Link to post
Share on other sites

the command is "installplg" and not "install"

 

so you need to run "installplg /boot/config/plugin/plex-0.9.3.5-noarch-0.2ds.plg"

 

Edit:

@spidi:

with something like this, you can make sure, that all inline files are updated without a reboot:

<!-- clean up previous install -->
<FILE Name="/tmp/cleanup" Run="/bin/bash">
<INLINE>
<![CDATA[
rm -f /etc/rc.d/rc.plex
rm -f -R /usr/local/emhttp/plugins/plex

rm /tmp/cleanup
]]>
</INLINE>
</FILE>

just make sure to insert it into the plg before the inline files...

0

Share this post


Link to post
Share on other sites

Forgive me if I'm being retarded :)  What's insulting? I can't find the joke.

 

::)

 

Guess I'm old fashioned whereby "old fashioned" I mean you don't normally step on someone else's toes who's already released a plugin for a system and has been actively supporting it, using his own code. That would normally constitute improper etiquette.

 

 

 

0

Share this post


Link to post
Share on other sites

Normally that wouldn't happen, I do agree. Generally you (the third party) would collaborate with the original plugin designer via PM or email, and come up with a solution that suits both parties.

 

Figured that was the case...  Perhaps a PM is in order Stokkes  :o

0

Share this post


Link to post
Share on other sites

@ Stokkes

 

yes, I was inspired by you, but this plugins has nothing to to do with your "code" (maybe the start script, and even that has only little changes from the original from plex) 

 

But I have to say I thought about thanking you ........... and then I forgot it writing the first post. Sorry.

 

I would hereby like to do that.

 

Sorry

0

Share this post


Link to post
Share on other sites

spidi: could you add following lines to the plex.sh file

export LC_ALL="en_US.UTF-8"
export LANG="en_US.UTF-8"

 

i've experienced some trouble when running as user nobody without setting the locale settings.

0

Share this post


Link to post
Share on other sites

spidi: could you add following lines to the plex.sh file

export LC_ALL="en_US.UTF-8"
export LANG="en_US.UTF-8"

 

i've experienced some trouble when running as user nobody without setting the locale settings.

 

Hi Benni,

 

when I do this

sudo -u nobody echo $LANG
en_US.UTF-8

and this

 sudo -u nobody locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

 

I already get what you want. accept LC_ALL. For what do you need this particularly one.??

0

Share this post


Link to post
Share on other sites

ok, it seems, if it is run via sudo, the locale settings are correct.

 

if it is run via su, the locale settings aren't correct...

su nobody -c locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

sudo -u nobody locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

 

so, maybe the locale settings aren't neccessary anymore when the pms is started via sudo

0

Share this post


Link to post
Share on other sites

Guess I'm old fashioned whereby "old fashioned" I mean you don't normally step on someone else's toes who's already released a plugin for a system and has been actively supporting it, using his own code. That would normally constitute improper etiquette.

I would agree with you, as I would expect some kind of pm correspondence prior to a redesign of something I had worked on.  In retrospect, I suppose it's reasonable to understand that we're in a kind of free-for-all development mode right now, since we have no agreed upon procedures for requests, designs, implementations, or maintenance of user sourced code on here.  Many of us learned standard coding practice in school or on the job, but I've dealt with far too many who just shoot from the hip.  While Tom is busy working on the hard stuff, we're entering into a kind of scripter's melee.  That being said, I appreciate spidi's initiative, even though I'm currently using Stokke's well-built plugin.  Were you planning work on a 5b11 version as well, Stokkes?

0

Share this post


Link to post
Share on other sites

I am still reading up about the new plugin system, will this auto update?

 

Also thanks to everyone who has worked on this project both old and new.

0

Share this post


Link to post
Share on other sites

@Dimtar

at the moment you have always to download the newest *.plg (*.xml or what ever it will be later) file.

 

This plugin file (plex-0.9.3.5-noarch-0.2ds.plg) always installs Plex 0.9.3.5.

But if I was't stoned for my rudeness until then, I will release an new version after Plex did.

 

0

Share this post


Link to post
Share on other sites

Cheers mate.

 

Just have to replace the *.plg fule and reboot, that's OK as that is way easier then today's current methods.

0

Share this post


Link to post
Share on other sites

Cheers mate.

 

Just have to replace the *.plg fule and reboot, that's OK as that is way easier then today's current methods.

 

only if you ran the application in /usr/local (in RAM).

at the moment this plugin don't remove an existing folder/file.

If your install directory is on cache drive. I can't update.

Maybe I implement this in the next release.

0

Share this post


Link to post
Share on other sites

so, maybe the locale settings aren't neccessary anymore when the pms is started via sudo

 

actually i have to correct myself.

without the export locale settings in the plex.sh file i get errors when scanning files with non ascii characters.

 

Aug 30, 2011 15:36:59 [0xb594e6d0] ERROR - Error in Python: Running scanner:
Traceback (most recent call last):
  File "/mnt/usenet/apps/PlexLibrary/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Series/Plex Series Scanner.py", line 44, in Scan
    VideoFiles.Scan(path, files, mediaList, subdirs)
  File "/mnt/usenet/apps/PlexLibrary/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Common/VideoFiles.py", line 141, in Scan
    Filter.Scan(path, files, mediaList, subdirs, video_exts)
  File "/mnt/usenet/apps/PlexLibrary/Plex Media Server/Plug-ins/Scanners.bundle/Contents/Resources/Common/Filter.py", line 24, in Scan
    if os.path.exists(filename) == False or os.path.getsize(filename) == 0:
  File "/usr/local/plex/Resources/Python/lib/python2.7/genericpath.py", line 18, in exists
    os.stat(path)
UnicodeEncodeError: 'ascii' codec can't encode character u'\u2019' in position 110: ordinal not in range(128)

 

with the two export lines in the plex.sh file, every file is scanned fine.

i think, "sudo -u nobody locale" returns the locale settings of the user root and these settings are used when starting plex.sh

but when the plex media scanner is started as user nobody, the nobody locale settings are used. because of this the two export lines in the plex.sh file are necessary

0

Share this post


Link to post
Share on other sites

Ok, I will include it in the next version. In the meantime it should not be a

problem for you to edit the file yourself. ;-)

0

Share this post


Link to post
Share on other sites

new version added

- some improvements

- check if plex is running, if not it starts it again.

0

Share this post


Link to post
Share on other sites

new version added

- some improvements

- check if plex is running, if not it starts it again.

 

you've got a little bug in your php file

 

<?=mk_option($plex_cfg['RUNAS'], "plex", "nobody");?>

should be

<?=mk_option($plex_cfg['RUNAS'], "nobody", "nobody");?>

 

otherwise the plugin want's to start plex as user "plex" when user "nobody" is selected.

 

 

edit:

also i think it's better to use "rm -f" in the cleanup script at the top of your plugin

using the -f parameter, any error message will be dismissed and not shown.

 

when first installing the plugin, none of these files exist, so the plugin installer will give some error messages...

0

Share this post


Link to post
Share on other sites

thanks, its done.

 

I tried something with the user plex, and forgot to remove it.

 

0

Share this post


Link to post
Share on other sites

I followed the directions in the first post, but I get "Plex has NOT started yes, Something is wrong!" when trying to enable it.  My settings are:

 

Install directory: /usr/local/plex

Library directory: /mnt/cache/.apps/plex

Temp directory: /mnt/cache/.apps/plex/tmp

Run as user: nobody

 

Ideas?

0

Share this post


Link to post
Share on other sites

Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.