Lacehim

Members
  • Content count

    254
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Lacehim

  • Rank
    Advanced Member

Converted

  • Gender
    Undisclosed
  1. I just turned on log deleted files and all the shares appeared listed. Give that a try.
  2. I just checked mine and it was stopped, which is strange because it was turned off before and working. Started it again, and same issue as your getting. It has picked up one share only which is empty. I'm running 6.3.3 and 2017.03.26 plugin that was updated a few days ago.
  3. Figured it out. Permissions was set as root, so ran the permissions script and it's working like a charm now. Phew.
  4. Is there a reason why this isn't working on some shares? I have nothing in excluded shares, but for some reason nothing is recycled in "Backups" but in "Documents" it is. It's a bit strange.
  5. Thanks dlandon This plugin has saved me in the past. I just noticed it wasn't working on 6.3 and found your update! Thanks for your hard work in making it happen.
  6. Thank you! That was it. SAB was missing that permissions setting! I must have missed it when I set it all up manually for the docker! Thank you so much! Sanity can be restored now! haha!
  7. Does no one else have this issue? First cache drive, and this is driving me crazy. Maybe it's caused by the docker apps... might look into that.
  8. Hi, I built myself a new server ages ago on V6 and put a cache drive in for the first time (I was using a self mounted apps drive). I copied all my data over from my old server (now my backup) and installed docker and plugin apps. Works great. The only issue I have is a permissions issues. I've created a .apps folder and put all my docker apps data in separate folders, but I can't edit, or delete or anything on the cache drive. It says I need permission from nobody to delete a file for example (that using Win 7 in explorer to delete). If I run the permissions script on the cache drive it fixes it, but anything new downloaded has the new permissions from nobody error. It's it a little annoying. The array is fine, and I have no permissions issues with it at all. Is there a way to fix this permanently? Seems to be that there's a setting somewhere that's giving new files the wrong permissions on the cache drive only. Thank you.
  9. Big thank you to dlandon for this plugin! Both servers upgraded to 6.1.2 with a working recycle bin! Cheers! And Thank you, thank you, thank you!
  10. Installed fine as an update. The RecycleBin folder didn't show anything when I accessed via Explorer after deleting a files or 2. In the plugin settings it said it had 20kb which was a few test files I was deleting so they were there, just not visable. I had to manually change permissions for for that folder and they magically appeared. My Windows 10 laptop however can't access the RecycleBin folder at all. Looks like it trying to connect as a domain instead of the Workgroup its set to. All other shares are accessible, and I can access it perfectly fine with my Windows 7 machine. Grrr. My feeling is that this is a Windows 10 issue, good old MS. I noticed in the extra folder that it's setting permissions to 777, is this working? Great work though dlandon! Quick work too! Really appreciated!
  11. Here's the smb-extra.conf off my 6.0.1 running the hacked plugin [global] security = USER#vfs_recycle_start #Recycle bin share [RecycleBin] path = /mnt/user/.Recycle.Bin read only = No #vfs config # Documentation http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html # Forum topic http://lime-technology.com/forum/index.php?topic=5446.0 # %S Samba share name (which in unRaid equals the user share name), eg. Storage # %P User share full path, eg /mnt/user/Storage # %u Username of the current service, if any # To apply changes execute: /etc/rc.d/rc.samba restart # If the single custom bin solution is chosen, create the dir manually, and grant it g+rwx permissions [global] vfs objects = recycle recycle:repository = /mnt/user/.Recycle.Bin recycle:directory_mode = 0777 recycle:keeptree = Yes recycle:touch = Yes recycle:touch_mtime = Yes recycle:versions = Yes recycle:exclude = *.tmp recycle:exclude_dir = .Recycle.Bin acl allow execute always = yes #vfs_recycle_end And the new v6.1 plugin code #vfs_recycle_start #Recycle bin share [RecycleBin] path = /mnt/user/.Recycle.Bin read only = No #vfs config # Documentation http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html # Forum topic http://lime-technology.com/forum/index.php?topic=5446.0 # %S Samba share name (which in unRaid equals the user share name), eg. Storage # %P User share full path, eg /mnt/user/Storage # %u Username of the current service, if any # To apply changes execute: /etc/rc.d/rc.samba restart # If the single custom bin solution is chosen, create the dir manually, and grant it g+rwx permissions [global] vfs objects = recycle recycle:repository = /mnt/user/.Recycle.Bin/%P recycle:keeptree = Yes recycle:touch = Yes recycle:touch_mtime = Yes recycle:versions = Yes recycle:exclude = *.tmp recycle:exclude_dir = .Recycle.Bin acl allow execute always = yes #vfs_recycle_end
  12. That's the one BRiT I knew it was somewhere! It seems to have disappeared from the plg that installs to the smb-extra.conf file. It's pretty important to is stores files differently if called the same on different shares.
  13. I think we should move all future comments about the 6.1 plugin to the new thread here http://lime-technology.com/forum/index.php?topic=42631.msg406899#new I think that will give you a fresh start dlandon and you'll know people are talking about your updated plg, and not previous version still available from this page.
  14. Hi dlandon, I tested this on my 6.1 backup system. It installed, and the settings are selectable and the recycle bin empties fine. I also clean installed it by removing the entries from smb-extra.conf and the old plg in files and backups. When it was installed I had to manually press enable, and SMB seemed to get trashed in the process but I stopped and started the array and all back to normal. It's better than the hacked to work version I was using now anyway! Great job! One thing not working is that when I trash a file called test.txt in a Backups folder it ends up in the recycle bin as test.txt. Previously it kept the folder structure /mnt/user/Backups/test.txt which is require IMO. I remember seeing a setting someone, might have been in the plg about maintaining folder structure. Keep up the good work! You've made my day!
  15. Cheers dlandon. A number of users are keen to get this up and running, but none of us have the knowledge to fix it and make it workable. Influencer is very busy and it's been left to it's own devices with people patching issues here and there. Happy to beta test it on my 6.1 backup system. It worked on 6.01 BUT the plugin part wasn't functional for settings etc. The actual recycle bin worked ok. In 6.1 it was still installed, but only the folder structure was recycled, the files weren't. I also tried just putting the code into the additional smb-extra.conf after removing the plugin and it still wouldn't work. It's a function that is lacking as a core option in unraid IMO. I lost lots of data back in the 4.7 days when windows explorer lagged while I was deleting a folder and poof, data gone! Lesson learned, I have backup unraid system that I manually sync now but I was a little naive back then!
Copyright © 2005-2017 Lime Technology, Inc. unRAIDĀ® is a registered trademark of Lime Technology, Inc.