jedimstr

Members
  • Content count

    71
  • Joined

  • Last visited

Community Reputation

3 Neutral

About jedimstr

  • Rank
    Advanced Member

Converted

  • Gender
    Undisclosed
  • Personal Text
    IAmYourFathersBrothers NephewsCousinsFormerRoomate
  1. Add option for remote syslog in WebGUI

    Well, I use a Splunk docker container for parsing the syslogs from all my home's servers and various network devices that have remote syslog capability (virtually all of them including routers, switches, wifi access points, console KVM servers, IOT devices, set top boxes, other docker containers, VirtualMachines, etc). It's pretty silly that everything on my network can feed their logs to Splunk on one of my unRAID servers, but the 2 unRAID servers I run don't. There are a lot of us using unRAID with Splunk or ELK setup for all our syslogs. It's kind of a basic feature for anything that deems itself a "server". There are hacky ways of making it work, but it's really something that should be available in Settings.
  2. Slack Notifications

    YES!!!!! Thank You!!!!!
  3. Slack Notifications

    I've attached a redacted version of my NotificationAgents.xml and the slack.png I used. Note that it wouldn't work unless I specified an actual webook URL in the XML's default value rather than relying on the form. NotificationAgents.xml
  4. Slack Notifications

    So... still no word on whether we can get this as a built-in feature in Notifications? Yes, it's fairly easy to setup, but even with User.scripts helping "automate" the process, it still has to be done after every version upgrade with potential for overwriting any new changes to the NotificationAgents.xml that we don't know about. It would be much better just to have the changes incorporated directly in the official releases. I mean I'd argue that Slack has many more users these days than some of the official Notification options like pushbullet or join.
  5. [REPO] dmaxwell351 repo - Air Video HD, splunk

    UPDATE: After multiple re-installs and restarts, variations on licensing (free vs trial), changing of file permissions to splunk:splunk, etc, I'm still having the same issue with Relative Search presets. The Real-time search presets work, but only show events going forward with no events prior to when the option is selected no matter which size time window. So collection is definitely working, categorizing is working, and the totals still do show up in the Dashboard Summary. But no historical data can be shown. I do see the following error messages on startup: Failed to start KV Store process. See mongod.log and splunkd.log for details. 6/4/2017, 12:43:54 PM KV Store changed status to failed. KVStore process terminated. 6/4/2017, 12:43:53 PM KV Store process terminated abnormally (exit code 1, status exited with code 1). See mongod.log and splunkd.log for details. 6/4/2017, 12:43:53 PM splunkd.log has these errors: 06-04-2017 12:43:53.407 -0400 ERROR MongodRunner - mongod exited abnormally (exit code 1, status: exited with code 1) - look at mongod.log to investigate. 06-04-2017 12:43:53.407 -0400 ERROR KVStoreBulletinBoardManager - KV Store process terminated abnormally (exit code 1, status exited with code 1). See mongod.lo g and splunkd.log for details. 06-04-2017 12:43:53.407 -0400 ERROR KVStoreBulletinBoardManager - KV Store changed status to failed. KVStore process terminated. mongo.log has these lines: 2017-06-04T15:31:39.576Z I JOURNAL [initandlisten] journal dir=/opt/splunk/var/lib/splunk/kvstore/mongo/journal 2017-06-04T15:31:39.577Z I JOURNAL [initandlisten] recover : no journal files present, no recovery needed 2017-06-04T15:31:39.788Z I JOURNAL [durability] Durability thread started 2017-06-04T15:31:39.788Z I JOURNAL [journal writer] Journal writer thread started 2017-06-04T15:31:39.790Z I CONTROL [initandlisten] ** WARNING: You are running this process as the root user, which is not recommended. 2017-06-04T15:31:39.790Z I CONTROL [initandlisten] 2017-06-04T15:31:39.790Z I CONTROL [initandlisten] 2017-06-04T15:31:39.790Z I CONTROL [initandlisten] ** WARNING: /sys/kernel/mm/transparent_hugepage/enabled is 'always'. 2017-06-04T15:31:39.790Z I CONTROL [initandlisten] ** We suggest setting it to 'never' 2017-06-04T15:31:39.791Z I CONTROL [initandlisten] 2017-06-04T15:31:39.791Z I INDEX [initandlisten] allocating new ns file /opt/splunk/var/lib/splunk/kvstore/mongo/local.ns, filling with zeroes... 2017-06-04T15:31:39.886Z E CONTROL [initandlisten] mmap() failed for /opt/splunk/var/lib/splunk/kvstore/mongo/local.ns len:16777216 errno:19 No such device 2017-06-04T15:31:39.886Z F INDEX [initandlisten] error couldn't open file /opt/splunk/var/lib/splunk/kvstore/mongo/local.ns terminating 2017-06-04T15:31:39.886Z I - [initandlisten] Invariant failure false src/mongo/db/storage/mmap_v1/catalog/namespace_index.cpp 239 2017-06-04T15:31:39.901Z I CONTROL [initandlisten]
  6. [support] Bungy's docker repository

    Thanks Bungy!!! Looks like the source you're using is a version behind. Your repo has 18.0 while the latest stable release from April is 18.1 (changelog: https://github.com/nzbget/nzbget/releases/tag/v18.1) The 19.x test versions are coming along nicely too, so don't know if you'd want to wait for that to update your container version.
  7. [support] Bungy's docker repository

    And... looks like an update of the container fixed it today. Github doesn't show any commits/releases though.
  8. [support] Bungy's docker repository

    Oh well... coincidental timing then. Still an issue, so I setup the binhex SABnzbd VPN container in the meantime. I prefered the more efficient C++ implementation in NZBget to the Python based SABnzbd, but the latest version 2.01 seems better than the older ones I've tried before and I don't want to download from usenet newsgroups without VPN so, SABnzbd it is for now.
  9. [support] Bungy's docker repository

    Getting the same error in the nzbgetvpn log as well. Just started this morning after the unRAID 6.3.5 upgrade. Along with the log error, the webGUI for nzbget gets a connection refused. Docker shows the container running. Other containers using VPN to PIA are working fine like activ-transmissionvpn so it's just isolated to nzbgetvpn.
  10. [REPO] dmaxwell351 repo - Air Video HD, splunk

    Having a weird issue with Splunk. I have a bunch of devices & servers on my network sending log data to UDP:514 on my Splunk container... events are showing up great in the dashboard and I can drill down to show hosts/sources/sourcetypes going into the thousands, so definitely getting data. But when I click on any to search for the actual events, no matter the filter choice, I always get "No Results Found". The data is there but source doesn't work. Tried from the default admin user and a new user just in case it was a roles or permissions issue, but no dice. Any ideas?
  11. [Support] Ninthwalker - NowShowing

    Yup, that repo and the readme referenced. It was a pain to initially setup awhile back but got lots of help on Reddit and other forums. Also, it may not be the actual issue, but from the evidence at hand it seems to be the case. Thanks!
  12. [Support] Ninthwalker - NowShowing

    So I guess no answer yet on supporting the HamaTV agent, or at least ignoring the Libraries using it in NowShowing? For now I'll have to stick with plexReport which ignores the Anime library and works perfectly well for email reports. You may want to think about the deprecation decision in Community Applications for plexReport while NowShowing has these limitations for now. I'm fairly certain I'm not the only person with a Plex Anime library using the popular HamaTV agent.
  13. [Support] Ninthwalker - NowShowing

    That shows up in any new docker container I create by default. I didn't add it either. Just added the container using Community Applications. unRAID ver. 6.3.3 but I've seen that path added to my containers since I first installed the 6.x versions.
  14. [Support] Ninthwalker - NowShowing

    My nowshowing.log file only has the following: I, [2017-05-10T07:24:02.596332 #789] INFO -- : Starting up NowShowing I, [2017-05-10T07:24:30.053409 #803] INFO -- : Starting up NowShowing I, [2017-05-10T07:25:06.979560 #806] INFO -- : Starting up NowShowing I, [2017-05-10T07:26:56.541504 #790] INFO -- : Starting up NowShowing I, [2017-05-10T07:27:24.723051 #802] INFO -- : Starting up NowShowing I, [2017-05-10T07:27:50.528648 #812] INFO -- : Starting up NowShowing I, [2017-05-10T07:34:10.088277 #813] INFO -- : Starting up NowShowing I, [2017-05-10T09:20:25.225163 #793] INFO -- : Starting up NowShowing I, [2017-05-10T09:21:09.614522 #790] INFO -- : Starting up NowShowing I, [2017-05-10T09:28:05.403990 #804] INFO -- : Starting up NowShowing I, [2017-05-10T09:28:26.846250 #813] INFO -- : Starting up NowShowing I, [2017-05-10T09:30:41.318496 #822] INFO -- : Starting up NowShowing I, [2017-05-10T09:31:14.694841 #807] INFO -- : Starting up NowShowing I, [2017-05-10T09:31:49.089850 #822] INFO -- : Starting up NowShowing I, [2017-05-10T23:30:00.704455 #835] INFO -- : Starting up NowShowing
  15. [Support] Ninthwalker - NowShowing

    I'm getting the same EOF error mentioned above but can't find what's wrong with my configuration. Test reports results in no test emails and the default NowShowing Page for the web report. /mnt/cache/appdata/nowshowing# docker exec nowshowing combinedreport -d -t -v /usr/local/sbin/combinedreport: end of file reached (EOFError) Docker log for this container shows: [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] 10-apply-perms: applying... [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] 10-apply-perms: applying... [fix-attrs.d] 10-apply-perms: exited 0. [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] 10-set-uidgid: executing... usermod: no changes ----------------------------------------- NowShowing ----------------------------------------- Brought to you by: Ninthwalker/GroxyPod/Limen75 ----------------------------------------- User xyz set to: 99 Group xyz set to: 100 ----------------------------------------- [cont-init.d] 10-set-uidgid: exited 0. [cont-init.d] 20-setup: executing... Advanced config file detected. Keeping existing files Setup complete! Please read directions for advanced settings and changing the schedule. [cont-init.d] 20-setup: exited 0. [cont-init.d] done. [services.d] starting services [services.d] done. docker exec nowshowing combinedreport -d -t is showing the correct settings matching my template, which are similar settings to what I'm already using successfully in plexReport. Switching to using a Plex Token doesn't fix anything. And no empty libraries. One difference I do have but don't know if it affects anything is that I have an Anime Library that's "TV Shows" Library type which uses the HamaTV agent and Absolute Series Scanner. This is a typical setup for anyone with an Anime library since theTVDB does not provide as complete listings and anime style series handling (single seasons that can span multiple years and 100's of episodes). This Library is currently ignored by plexReport without any changes to config. I wonder if it could be tripping up NowShowing? Help!!!
Copyright © 2005-2017 Lime Technology, Inc. unRAIDĀ® is a registered trademark of Lime Technology, Inc.