barakthecat

Members
  • Content count

    82
  • Joined

  • Last visited

Community Reputation

0 Neutral

About barakthecat

  • Rank
    Advanced Member
  • Birthday

Converted

  • Gender
    Undisclosed
  1. I followed Peter_sm's directions and fixed the Security and Setup warnings, but I am also having the Request Entity too Large when trying to upload files larger than a few hundred MB. Anyone have a solution for that?
  2. Thanks Bjonness406 and EdgarWallace (and of course kamhighway for the instructions). I had some typos along the way that of course messed the whole thing up. So I've got it working now if I got to https://mydomain.com/nextcloud but what I'd like to do is https://nextcloud.mydomain.com. Right now that just goes to my default index page. Any directions for making that work?
  3. Apparently as of Mac OS Sierra 10.12, Time Machine can run over SMB. However there is some work that needs to happen to make this work, so not just any SMB share will appear. Apple has a specification page for Time Machine over SMB. I know LimeTech has wanted to drop AFP support, getting Time Machine running over SMB would surely drop my resistance to that! https://developer.apple.com/library/content/releasenotes/NetworkingInternetWeb/Time_Machine_SMB_Spec/
  4. I seem to have fixed it. Looks like I had a lot of old VM related files from the v6.0 betas and beyond. I cleaned those up and then deleted my domains.cfg and reimported my XML and everything seems to be normal now. Move along . . . nothing to see here . . .
  5. Hi all, I recently upgraded from 6.1.8 to 6.2 and am having trouble with my VMs. I have toggled Enable VMs in the VM Manager and deleted my libvert.img and then turned back on. I get a list of my 3 VMs as was shown in 6.1.8 and they work fine. If I go to create a new VM - either by scratch XML or by template I get issues. First is when I hit the Create button on the template it just hangs on that screen. If I wait a while and then go to the list of the VMs, I see the newly created machine there, but the top of the page is filled with error messages: Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): ^ in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 The system log shows Oct 8 06:25:54 StrongBad root: Devices: Oct 8 06:25:54 StrongBad root: ID SIZE PATH Oct 8 06:25:54 StrongBad root: 1 1.00GiB /mnt/cache/system/libvirt/libvirt.img Oct 8 06:25:54 StrongBad root: Oct 8 06:25:54 StrongBad kernel: BTRFS: device fsid b8fbadea-119a-4d4e-9740-112b9e75e6dd devid 1 transid 5 /dev/loop2 Oct 8 06:25:54 StrongBad kernel: BTRFS info (device loop2): disk space caching is enabled Oct 8 06:25:54 StrongBad kernel: BTRFS: has skinny extents Oct 8 06:25:54 StrongBad kernel: BTRFS: flagging fs with big metadata feature Oct 8 06:25:54 StrongBad kernel: BTRFS: creating UUID tree Oct 8 06:25:54 StrongBad root: initializing /etc/libvirt Oct 8 06:25:54 StrongBad kernel: EXT4-fs (loop3): mounted filesystem with ordered data mode. Opts: (null) Oct 8 06:25:55 StrongBad emhttp: shcmd (297949): /etc/rc.d/rc.libvirt start |& logger Oct 8 06:25:55 StrongBad root: Starting libvirtd... Oct 8 06:25:55 StrongBad kernel: tun: Universal TUN/TAP device driver, 1.6 Oct 8 06:25:55 StrongBad kernel: tun: © 1999-2004 Max Krasnyansky <maxk@qualcomm.com> Oct 8 06:25:56 StrongBad kernel: device virbr0-nic entered promiscuous mode Oct 8 06:25:56 StrongBad avahi-daemon[12270]: Joining mDNS multicast group on interface virbr0.IPv4 with address 192.168.122.1. Oct 8 06:25:56 StrongBad avahi-daemon[12270]: New relevant interface virbr0.IPv4 for mDNS. Oct 8 06:25:56 StrongBad avahi-daemon[12270]: Registering new address record for 192.168.122.1 on virbr0.IPv4. Oct 8 06:25:56 StrongBad kernel: virbr0: port 1(virbr0-nic) entered listening state Oct 8 06:25:56 StrongBad kernel: virbr0: port 1(virbr0-nic) entered listening state Oct 8 06:25:56 StrongBad dnsmasq[5244]: started, version 2.76 cachesize 150 Oct 8 06:25:56 StrongBad dnsmasq[5244]: compile time options: IPv6 GNU-getopt no-DBus i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth no-DNSSEC loop-detect inotify Oct 8 06:25:56 StrongBad dnsmasq-dhcp[5244]: DHCP, IP range 192.168.122.2 -- 192.168.122.254, lease time 1h Oct 8 06:25:56 StrongBad dnsmasq-dhcp[5244]: DHCP, sockets bound exclusively to interface virbr0 Oct 8 06:25:56 StrongBad dnsmasq[5244]: reading /etc/resolv.conf Oct 8 06:25:56 StrongBad dnsmasq[5244]: using nameserver 192.168.1.1#53 Oct 8 06:25:56 StrongBad dnsmasq[5244]: read /etc/hosts - 2 addresses Oct 8 06:25:56 StrongBad dnsmasq[5244]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses Oct 8 06:25:56 StrongBad dnsmasq-dhcp[5244]: read /var/lib/libvirt/dnsmasq/default.hostsfile Oct 8 06:25:56 StrongBad kernel: virbr0: port 1(virbr0-nic) entered disabled state Oct 8 06:27:29 StrongBad kernel: device vnet0 entered promiscuous mode Oct 8 06:27:29 StrongBad kernel: br0: port 2(vnet0) entered forwarding state Oct 8 06:27:29 StrongBad kernel: br0: port 2(vnet0) entered forwarding state Oct 8 06:27:41 StrongBad kernel: kvm: zapping shadow pages for mmio generation wraparound Oct 8 06:27:41 StrongBad kernel: kvm: zapping shadow pages for mmio generation wraparound Oct 8 06:28:50 StrongBad kernel: br0: port 2(vnet0) entered disabled state Oct 8 06:28:50 StrongBad kernel: device vnet0 left promiscuous mode Oct 8 06:28:50 StrongBad kernel: br0: port 2(vnet0) entered disabled state and the libvirt log shows: 2016-09-23 03:20:04.639+0000: 27391: error : virNetDevGetLinkInfo:2656 : unable to read: /sys/class/net/veth9a71bf7/operstate: No such file or directory 2016-09-23 03:22:30.338+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-23 03:22:30.346+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-23 03:22:30.357+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-23 03:22:30.367+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-23 03:22:30.377+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-23 03:22:30.386+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-23 03:22:30.395+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-23 03:22:30.401+0000: 27391: error : virFileReadAll:1376 : Failed to open file '/sys/class/net/vethae18642/operstate': No such file or directory 2016-09-23 03:22:30.401+0000: 27391: error : virNetDevGetLinkInfo:2656 : unable to read: /sys/class/net/vethae18642/operstate: No such file or directory 2016-09-29 19:58:01.350+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 19:58:01.362+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 19:58:01.371+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 19:58:01.378+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 19:58:01.384+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 19:58:01.391+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 19:58:01.399+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 19:58:01.404+0000: 27391: error : virFileReadAll:1376 : Failed to open file '/sys/class/net/veth516664f/operstate': No such file or directory 2016-09-29 19:58:01.404+0000: 27391: error : virNetDevGetLinkInfo:2656 : unable to read: /sys/class/net/veth516664f/operstate: No such file or directory 2016-09-29 20:07:15.060+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 20:07:15.069+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 20:07:15.075+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 20:07:15.083+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 20:07:15.089+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 20:07:15.106+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 20:07:15.115+0000: 27391: error : virNetDevSendEthtoolIoctl:3191 : ethtool ioctl error: No such device 2016-09-29 20:07:15.121+0000: 27391: error : virFileReadAll:1376 : Failed to open file '/sys/class/net/veth48e60c7/operstate': No such file or directory 2016-09-29 20:07:15.121+0000: 27391: error : virNetDevGetLinkInfo:2656 : unable to read: /sys/class/net/veth48e60c7/operstate: No such file or directory 2016-10-08 03:32:59.067+0000: 27394: warning : qemuDomainObjTaint:2223 : Domain id=2 name='MacOSX-10.11' uuid=0ba39646-7ba1-4d41-9602-e2969a3fc26d is tainted: high-privileges 2016-10-08 03:32:59.067+0000: 27394: warning : qemuDomainObjTaint:2223 : Domain id=2 name='MacOSX-10.11' uuid=0ba39646-7ba1-4d41-9602-e2969a3fc26d is tainted: custom-argv 2016-10-08 09:45:57.477+0000: 27392: warning : qemuDomainObjTaint:2223 : Domain id=3 name='MacOSX-10.11' uuid=0ba39646-7ba1-4d41-9602-e2969a3fc26d is tainted: high-privileges 2016-10-08 09:45:57.477+0000: 27392: warning : qemuDomainObjTaint:2223 : Domain id=3 name='MacOSX-10.11' uuid=0ba39646-7ba1-4d41-9602-e2969a3fc26d is tainted: custom-argv 2016-10-08 10:11:42.089+0000: 27391: error : qemuMonitorIO:689 : internal error: End of file from monitor 2016-10-08 10:27:29.211+0000: 5162: info : libvirt version: 1.3.1 2016-10-08 10:27:29.211+0000: 5162: info : hostname: StrongBad 2016-10-08 10:27:29.211+0000: 5162: warning : qemuDomainObjTaint:2223 : Domain id=1 name='Windows7' uuid=2e21b531-7d7c-5031-eaab-90b0d4456b1b is tainted: high-privileges 2016-10-08 10:27:29.211+0000: 5162: warning : qemuDomainObjTaint:2223 : Domain id=1 name='Windows7' uuid=2e21b531-7d7c-5031-eaab-90b0d4456b1b is tainted: host-cpu 2016-10-08 10:28:50.678+0000: 5157: warning : qemuAgentNotifyEvent:1245 : Received unexpected event 1 (expected 0) 2016-10-08 10:28:52.717+0000: 5157: error : qemuAgentIO:635 : internal error: End of file from monitor 2016-10-08 10:28:52.717+0000: 5157: error : qemuMonitorIO:689 : internal error: End of file from monitor This happens no matter what template I choose or if I make the XML from scratch. Any suggestions?
  6. I haven't been able to get an SMB mount to show up as an option in TimeMachine. Apple's documentation states "Note: Some SMB and AFP disks from manufacturers other than Apple don’t support Time Machine. If your network uses an SMB or AFP disk, but the disk doesn’t appear in the list of devices available for Time Machine backups, contact the disk’s manufacturer." So not sure what needs to happen for this to work on unRAID, but would love to see it happen. I know Lime Tech has wanted to shut off AFP for a while, this is the path to make that happen!
  7. So I'm stuck. I've got the container installed and reachable over my domain name and it serves us up the default landing page. I've got basic authentication enabled. But how do I get it to redirect to subdomains? so that cloud.mydomain.com goes to one docker and cp.mydomain.com goes to another? Everything just goes to the same default page. Also, any help with doing this with owncloud or nextcloud would be greatly appreciated (as it's the primary point for me). here's my default config server { listen 443 ssl default_server; ssl_certificate /config/keys/fullchain.pem; ssl_certificate_key /config/keys/privkey.pem; ssl_dhparam /config/nginx/dhparams.pem; ssl_protocols TLSv1 TLSv1.1 TLSv1.2; ssl_ciphers 'idontknowifishouldpublishthisnumber$ ssl_prefer_server_ciphers on; client_max_body_size 0; location / { root /config/www; index index.html index.htm index.php; auth_basic "Restricted"; auth_basic_user_file /config/nginx/.htpasswd; } location /router { auth_basic "Restricted"; auth_basic_user_file /config/nginx/.htpasswd; include /config/nginx/proxy.conf; proxy_pass http://192.168.x.xxx:80/router; } location /cloud { auth_basic "Restricted"; auth_basic_user_file /config/nginx/.htpasswd; include /config/nginx/proxy.conf; proxy_pass http://192.168.x.xxx:8008/cloud; } }
  8. Thanks everyone for all the hard work on this. I'm stuck with a problem relating to VMs. When I go to the VM tab I see my 3 previously created VMs, all off as I RTFM and set them to not auto start. I wanted to check things out before starting them so I went to create a new VM by clicking on Templates and then selecting the OpenELEC prepackaged VM. It downloads the ISO just fine and then when I go to create the the VM (leaving everything at default) it just sits on "creating . . ." The folders are made in my appdata folder and the VM can run, but it never competes the creating step. The next issue is that if I leave the page while it sits on creating and go back, I get an error message Warning: libvirt_domain_xml_xpath(): namespace warning : xmlns: URI unraid is not absolute in /usr/local/emhttp/plugins/dynamix.vm.manager/classes/libvirt.php on line 936 Warning: libvirt_domain_xml_xpath(): and the screen is messed up It also affects the Dashboard Any ideas?
  9. I used to use Microsoft Remote Desktop Connection, but now I use the Crashplan-Desktop docker.
  10. Thanks, going to try this out today!
  11. Thanks for the help. I ran it three time and got the following message btrfs check --repair /dev/md3 enabling repair mode Checking filesystem on /dev/md3 UUID: a689b3d7-49ad-4e1f-94e4-73e7766234b8 checking extents Fixed 0 roots. checking free space cache cache and super generation don't match, space cache will be invalidated checking fs roots checking csums checking root refs found 655325340261 bytes used err is 0 total csum bytes: 639124824 total tree bytes: 861519872 total fs tree bytes: 134070272 total extent tree bytes: 46743552 btree space waste bytes: 61750185 file data blocks allocated: 1926415949824 referenced 639287005184 btrfs-progs v4.1.2 When I restarted the array the drive mounted as usual and I don't see any evidence of data loss. I'm thinking of just reformatting the disk to be sure though. It's all backup data on there and now I don't feel I can trust it. Losing my historical backup of 2 laptops isn't even a little deal to me. Any other suggestions?
  12. Hi all, I just upgraded from 6.1.6 to 6.1.7 and when my system came back up, my Disk 3 was listed as Unmountable. The disk shows a green ball and the SMART status gives me a green thumbs up. The settings page says File System Status: Unmountable - No file system (32) I believe the disk had been formatted as BTRFS, though it might have been XFS. I have a current offsite backup of my files (love that Crashplan Docker), and actually the data on Disk 3 is of minimal importance - the Disk is dedicated to a Time Machine share and is excluded from my other shares. As long as I get running again before I have a HD crash on one of my Mac's I am good. Attached is the Diagnostics zip file. Please let me know what to do next. Thanks all! strongbad-diagnostics-20160206-1800.zip
  13. just upgraded from 6.1.6 to 6.1.7 and one of my disks is showing up as Unmountable with a Green Ball. The settings page says No File System 32. It was either XFS or BTRFS. None of the data on there was important in the short-term (dedicated to Time Machine backups, so as long as I can get backed up again before a HD failure I'm good). What do I do next?
  14. I don't see why you couldn't just set a plugin directory in the template* * says the guy who knows nothing about any of this
  15. I'm with you, but I've just installed the Krusader Docker app and find this to be much faster to access. Just putting it out there as alternative. -- Jason
Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.